Streamcord - Dashboard performance issues – Incident details

YouTube Notifications experiencing partial outage

Dashboard performance issues

Resolved
Degraded performance
Started almost 5 years agoLasted about 2 hours
Updates
  • Resolved
    Resolved

    We have deployed the fix. However, we will continue to monitor the service until there are no signs of regression. Thanks a ton for your patience.

  • Investigating
    Investigating

    Streamcord's Dashboard is currently experiencing some issues causing pages to be extremely slow or not load at all. We're looking into the issue.