Started over 4 years agoOctober 31, 2021Lasted about 13 hoursOctober 31, 20212:28 PMNovember 01, 20213:31 AMUTC
Updates
Resolved
UTC
Resolved
UTC
This issue has been resolved.
Investigating
UTC
Investigating
UTC
Streamcord's Dashboard is currently experiencing some issues causing certain pages to be extremely slow or not load at all. We're looking into the issue.